Pagebar2 文章分頁外掛,讓翻頁更容易!

如果你網站的文章數量蠻多的,每當想要跳到某頁找文章,若是沒裝個外掛應該很麻煩,因為你要用WordPress本身的上一頁、下一頁慢慢翻,還沒翻到可能就天黑了,這時候來個文章分頁數字外掛,那我們就選用「Pagebar2」這外掛來讓你的訪客或是你自己可以更快速的翻到某一頁的文章!


WordPress本身首頁下方的翻頁模式時在不是很好用,這時候我們可以善加利用文章分頁外掛,讓文章更好翻。不過在安裝外掛前,似乎有幾個BSP網站本身都沒有這類的功能,像是無名小站以及Blogger,不過痞客邦倒是可以讓使用者很快速的翻頁喔!其實我還蠻納悶為什麼官方不把此功能內建在WordPress內,這不是一個蠻不錯的文章翻頁外掛嗎?希望哪一版本的WordPress可以把它包進去,這樣就不用每次換佈景都要改了。

外掛名稱:Pagebar2
功能說明:讓首頁、分類、彙整等頁面的文章分頁化。
官方網站http://www.elektroelch.de/hacks/wp/pagebar/
外掛下載按這裡 (2.21版)
中文語系按這裡下載 (正體中文語系檔)
備註事項:WordPress版本必須2.3以上(目前在WordPress2.8可正常)

第1步 首先來到WordPress後台,點擊【外掛】→【新增】,進入後在搜尋欄位輸入「Pagebar」並點擊﹝搜尋外掛﹞。

Pagebar2安裝教學、中文語系下載

第2步 接著找到名為「Pagebar」的外掛,點擊右方的「安裝」。

Pagebar2安裝教學、中文語系下載

第3步 雖然畫面上告知你在WordPress2.8還沒測試過,但事實上應該沒問題,可能只是原作者沒去更新官方資訊,請點擊﹝立刻安裝﹞。

Pagebar2安裝教學、中文語系下載

第4步 接著系統就會開始自動安裝外掛,安裝完成後請點擊「啟用外掛」,這樣外掛就啟用囉!

Pagebar2安裝教學、中文語系下載

第5步 接著請下載Pagebar2正體中文語系檔,下載後啟解壓縮,請將兩個檔案上傳到FTP中的「/wp-content/plugins/pagebar/language」目錄下就可以囉!

Pagebar2安裝教學、中文語系下載

第6步 這時你可以到外掛測試頁面,請點擊【設定】→【Pagebar】,進入後你就可以開始針對你自己的需求設定囉!如果你想要讓你的分頁外掛好看一點,最下方樣式表可以選擇【pagebar.css】。

Pagebar2安裝教學、中文語系下載

第7步 請將外掛此資料夾「/wp-content/plugins/pagebar」內的pagebar.css檔案下載回來,並將他丟到「/wp-content/themes/您正在使用的佈景」下。這樣才能正確顯示出比較好看的樣式喔!

Pagebar2安裝教學、中文語系下載

第8步 當設定完成後,可以趕快回到首頁看看,是不是呈現出來呢?

Pagebar2安裝教學、中文語系下載

為什麼會有兩串下一頁的按鈕?

基本上此外掛可以不用修改程式碼就可以讓分頁按鈕呈現出來,但是蠻多佈景沒有符合標準寫法,所以可能會造成外掛內設定的「移除預設的網站導航功能」失效,變成網頁上會有兩種下一頁的按鈕。以目前熱門的iNove版型來說,大概就會變成以下的樣子。

Pagebar2安裝教學、中文語系下載

所以若要解決這問題,您可以開啟佈景檔中的index.php這檔案,將以下語法刪除:

<div id="pagenavi">
  <?php if(function_exists('wp_pagenavi')) : ?>
        <?php wp_pagenavi() ?>
    <?php else : ?>
        <span class="newer"><?php previous_posts_link(__('Newer Entries', 'inove')); ?></span>
        <span class="older"><?php next_posts_link(__('Older Entries', 'inove')); ?></span>
    <?php endif; ?>
    <div class="fixed"></div>
</div>

然後在原本的位置上加上以下語法:

<div class="navigation">  <center>

<?php if (function_exists('wp_pagebar')) wp_pagebar();?>  </center>  </div>

Pagebar2安裝教學、中文語系下載

按照以上方法操作應該就可以正常運作囉!不過若你是其它的佈景,那就請您自行研究一下程式碼做一下修正吧!目前這外掛我用蠻久了,在WordPress2.8上也可以正常運作,雖然官方只說支援到2.3,不過WordPress可能本身系統函數沒有大變動的話,其實一些舊版的外掛還是可以裝在新版的程式上面喔!